• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

need help : urgent

 
Sreeraj G Harilal
Ranch Hand
Posts: 310
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello ranchers,
I trying to start SCBCD preparation. To begin i prefer Head First EJB.
There is no Head First series for EJB 3.0 so i bought Head First EJB (version 2.0) to begin my study.
I am using Sun Microsystem's Application Server PE 8 (J2EE 1.4).
I suppose Head First is using J2EE 1.3

In chapter 1 (Intro to EJB) of Head First, it shows how to create a SessionBean and package it to a jar file using Deploytool of Application Server.
I follow the same steps to creating and packaging my first EJB.
I created and compiled the Bean classes successfully.
But when i try to create the jar file using Deploytool a warning messgae says
"The class(headfirst.AdvceBean)could not be loaded: Please consult online help for assistance in setting up the class root directory and class files"


when the dialog message comes?

1)New Enterprise Bean Wizard: EJB JAR General Settings [/B] window).
2)I added the three bean classes (with package folder) to the contents tree of deploytool EJB wizard.
3) click next.


Please tell me a way to solve this problem.
Its really urgent because i am struck with in starting.
 
Nicholas Cheung
Ranch Hand
Posts: 4982
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
That piece of codes contain some problems. Please refer to the errata to fix the problem.

Nick
 
Sreeraj G Harilal
Ranch Hand
Posts: 310
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Nicholas Cheung, I checked the errata and i make necessary changes but still i have the same problem when i try to create jar files using Diploytool wizard.

Must i use J2EE 1.3 to avoid these problem?
 
Mikalai Zaikin
Ranch Hand
Posts: 3365
11
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Sreeraj G H:


Must i use J2EE 1.3 to avoid these problem?


As far as I remember, HF EJB assumes you use J2EE 1.3.
 
Celinio Fernandes
Ranch Hand
Posts: 549
Eclipse IDE Google Web Toolkit Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
J2EE 1.3 is the version that you have to use to prepare for SCBCD 1.3
[ January 04, 2007: Message edited by: Celinio Fernandes ]
 
Sreeraj G Harilal
Ranch Hand
Posts: 310
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks everybody, for your response.
Celinio,if latest version is here why do i go for SCBCD 1.3?
I got another book named Mastering EJB 3.0. So i am going to start with that book.
 
Rajan Murugan
Ranch Hand
Posts: 182
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Sreeraj G H:
Thanks everybody, for your response.
Celinio,if latest version is here why do i go for SCBCD 1.3?
I got another book named Mastering EJB 3.0. So i am going to start with that book.


Atleast once if you go through hfejb (1.3 based),it will be good.It will be helpful in interoperability and other topics(exception,security,transaction, mdb) atleast till the new hfejb is available.
 
Sreeraj G Harilal
Ranch Hand
Posts: 310
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Yes Rajan Murugan, i will do.
Actually i like Head First series thats why i bought the book "Head First EJB" first.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic