Win a copy of Svelte and Sapper in Action this week in the JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Bear Bibeault
  • Junilu Lacar
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • salvin francis
  • Frits Walraven
Bartenders:
  • Scott Selikoff
  • Piet Souris
  • Carey Brown

which scbcd version I have to take after scjp 1.4

 
Greenhorn
Posts: 11
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello everybody
I am new to this forum.First time I am posting a question in it.
I completed scjp 1.4 and scwcd 1.4 exam.Now I want to give exam scbcd.I searched on net,It is showing versions of scbcd as scbcd 1.3 and scbcd 1.5.
Which version exam I can give ?scbcd 1.3/Scbcd 1.5?what about scbcd 1.4?This version is not exist or what?which is the latest version?Head first EJB book I bought it.Is it for scbcd 1.3 or scbcd 1.5?
scbcd 1.3 covers EJB 2.0 or EJB 3.o?for which exam I can appear after giving scjp1.4?

I have lot of confusion before starting preparation.I have only 2 months remaining for exam.Please let me know the above details.
 
Sheriff
Posts: 14691
16
Eclipse IDE VI Editor Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Arpita,

As you said, there are two different versions of the SCBCD :
- Sun Certified Business Component Developer for the Java Platform, Enterprise Edition 5 (CX-310-091)
- Sun Certified Business Component Developer for Java 2 Platform, Enterprise Edition 1.3 (CX-310-090)

The latest is Edition 5.

SCBCD1.3 is about EJB2.0, whereas SCBCD5 is about the brand new EJB3.0.
Head First EJB is aimed at SCBCD1.3, the old exam. There's no Head First books for version 5 yet. And I don't think there's any plan to release one soon.

With Scjp1.4, you can go for any of them.

EJB3 is a fairly new subject, and there are only few documentation on it. I don't think there are books aimed specifically at the exma yet (may be wrong).
EJB2 and EJB3 are two different beasts, so you may decide on which one to go for, depending on your requirements.

Good luck.
 
arpita kale
Greenhorn
Posts: 11
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thank you very much for the reply.One more question is If I gave scbcd 1.3 then is it useful for me in future?or is it like that it is totally out dated so giving this exam is just waste of time.
Because if documents for scbcd 1.5 are less then I will prefer to go for scbcd 1.3.I have only 2 months remaining for exam praparation.so better to go for scbcd 1.3.But please clerify my above doubt that how it is useful to give this exam in future ?
 
Christophe Verré
Sheriff
Posts: 14691
16
Eclipse IDE VI Editor Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I don't find SCBCD1.3 out-of-date. There are plenty of projects still using EJB2.X.
3.0 is still fresh, and may need time to get adopted by companies.
If you go for SCBCD1.3, there's also an upgrade exam for 5.0 which you can take afterwards, when you've got more time :
- Sun Certified Business Component Developer for the Java Platform, Enterprise Edition 5 Upgrade Exam (CX-310-092)
 
You don't like waffles? Well, do you like this tiny ad?
Thread Boost feature
https://coderanch.com/t/674455/Thread-Boost-feature
    Bookmark Topic Watch Topic
  • New Topic