Win a copy of The Java Performance Companion this week in the Performance forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

JDK 6 and J2EE 1.31 Compatibility

 
Javier Sanchez Cerrillo
Ranch Hand
Posts: 152
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi ranchers. I'd like to know if there are compatibility issues between these 2.

I have installed both JDK 6 and J2EE 1.3.1 on my system and I'm following "Head First EJB" from Kathy and Bert.

When I start "j2ee -verbose", I get the following error:

Exception in thread "main" java.lang.NoClassDefFoundError
com/sun/corba/se/internal/util/IdentityHashTable

Followed by a Stack Trace.

Regards and Thank you!
 
Shivani Chandna
Ranch Hand
Posts: 380
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
advised to use only jdk1.3 with j2ee1.3

rgds.
 
srini sri
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
J2EE 1.3 works with jdk 1.3 and jdk 1.4

In headfirst book it was said that some version of jdk 1.3 has some bug in working with j2ee (people: dont take this seriously). so, i suggest is jdk 1.4.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic