• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

question about APIs in EJB3

 
Michael Maier
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello,

I have a problem with the following mock exam question (com.enthuware.ets.scbcd.v5.2.203 from enthuware):

Which of the following APIs may an enterprise bean developer use without jeopardizing the portability of the enterprise bean?

a) JMS
b) JDBC
c) JCA
d) JAXR
e) ADO


a) and b) are right but why do c) and d) jeopardizing the portability of the bean? The specification lists them as required APIs in EJB3.

Thanks for your help,

Michael
 
Benoît de Chateauvieux
Ranch Hand
Posts: 183
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Michael,

I answered wrong in this question too.
My error was because O'Reilly write about Connectors as JCA (Java Connector API) in the chapter 1.3.2.

But if you look in the Sun's web site, JCA is "Java Cryptography Architecture" that is not required by the EJB3.0 spec.

I don't know why the use of JAXR may jeopardize the portability of your bean.
Did you open a ticket in the Enthuware Support ?

Beno�t
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic