Win a copy of Beginning Java 17 Fundamentals: Object-Oriented Programming in Java 17 this week in the Java in General forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Tim Cooke
  • Campbell Ritchie
  • Ron McLeod
  • Liutauras Vilda
  • Jeanne Boyarsky
Sheriffs:
  • Junilu Lacar
  • Rob Spoor
  • Paul Clapham
Saloon Keepers:
  • Tim Holloway
  • Tim Moores
  • Jesse Silverman
  • Stephan van Hulst
  • Carey Brown
Bartenders:
  • Al Hobbs
  • Piet Souris
  • Frits Walraven

Problems configuring J2EE-SDK 1.3

 
Ranch Hand
Posts: 346
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi
I downloaded n installed J2ee SDK 1.3 01 .
( my machine is Celeron 566 , 64 MB , Win98 OSR2 )
After reading docs , i set da J2EE_HOME variable as required.
set J2EE_HOME = c:\j2sdkee1.3
( Java_Home is also properly set , along wid Path/Classpath settings )
set JAVA_HOME=c:\jdk
set CLASSPATH=c:\jdk\lib; c:\jdk\jre\lib\rt.jar
set PATH=C:\JDK\BIN ; c:\j2sdkee1.3\bin

Now when i run setenv.bat file , it gives syntax errors for following 3 commands in batch file :
set JAAS_OPTIONS= -Djava.security.auth.policy=%J2EE_HOME%\lib\security\jaas.policy
set SSL_OPTIONS= -Djavax.net.ssl.trustStore=%J2EE_HOME%\lib\security\cacerts.jks
set LISTEN_OPTIONS= -Dcom.sun.CORBA.connection.ORBListenSocket=SSL:0,SSL_MUTUALAUTH:0,PERSISTENT_SSL:1060

Errors are displayed as :
<font color="blue">
C:\j2sdkee1.3\bin>set JAAS_OPTIONS= -djava.security.auth.policy=c:\j2sdkee1.3\li
b\security\jaas.policy
Syntax error
C:\j2sdkee1.3\bin>set SSL_OPTIONS= -djavax.net.ssl.trustStore=c:\j2sdkee1.3\lib\
security\cacerts.jks
Syntax error
C:\j2sdkee1.3\bin>set LISTEN_OPTIONS= -dcom.sun.CORBA.connection.ORBListenSocket
=SSL:0,SSL_MUTUALAUTH:0,PERSISTENT_SSL:1060
Syntax error
</font>

As setenv.bat has to be run sucessfully bfore running any other J2EE tool's script .So I am not able to go forward .

If i manually fill the values of these variables in J2EE command-scripts , then i get windows-message as
"This program has done illegale operation , and will be shut down..blah blah.."

Plzz helpp .. not able to proceed wid J2EE .
( have installed Tomcat tho , its working fine )

------------------
Gagan (/^_^\) SCJP2
Die-hard JavaMonk -- little Java a day , keeps u going .
 
Ranch Hand
Posts: 96
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Did you use jdk1.3.1_01?
 
Gagan Indus
Ranch Hand
Posts: 346
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
yes RuiJin . i am using jdk1.3.1_01 as its latest n confirms to Servlet2.3/JSP1.2
any solutions to ma prob ??
------------------
Gagan (/^_^\) SCJP2
Die-hard JavaMonk -- little Java a day , keeps u going .
 
ruijin yang
Ranch Hand
Posts: 96
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I mean that your JAVA_HOME should be version of jdk1.3.1_01. You can report
your problem to SUN:j2ee-ri-feedback@sun.com
Hope your problem solved soon.
ruijin yang
 
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Gagan -
a doubt?!... after setting JAVA_HOME and J2EE_HOME, did you add them to your CLASSPATH??
I mean:
set JAVA_HOME=...
set J2EE_HOME=...
set CLASSPATH=%JAVA_HOME%;%J2EE_HOME%;(...the rest goes here...)
~Kavitha
[This message has been edited by Kavitha Adimurthy (edited October 20, 2001).]
 
Gagan Indus
Ranch Hand
Posts: 346
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Thankx Ruijin , Kavitha
Kavitha , i had not set my classpath as u recommended , but is it really required?
as even after changing the classpath as u sed , i was still facing same problems.
But , hurrah ! at last i am able to start J2ee server sucessfully
All i did was , i commented out those problematic 'set' commands in setenv.bat , wid 'rem' .
And whereever these env-variables were required in other script files , i replaced their name wid their full-value given in setenv.bat
I was already trying this , but somehow i wasnt doin it rite way
But now its running
Thankx u guyz for ur help

------------------
Gagan (/^_^\) SCJP2
Die-hard JavaMonk -- little Java a day , keeps u going .
 
WHAT is your favorite color? Blue, no yellow, ahhhhhhh! Tiny ad:
Building a Better World in your Backyard by Paul Wheaton and Shawn Klassen-Koop
https://coderanch.com/wiki/718759/books/Building-World-Backyard-Paul-Wheaton
reply
    Bookmark Topic Watch Topic
  • New Topic