Win a copy of The Little Book of Impediments (e-book only) this week in the Agile and Other Processes forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

tomcat

 
ramymoneiry4
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
dear all
I installed tomcat 4.0 on windows 2000 at the directory c:\tomcate4.0 ,
it work good but I have two problems :
1- when I shutdown the server from by shutdown.bat I find the following
error
exception in thread main , java.lang.NoClassDefFoundError:
4/0\jakarta-tomcat-4/0-b5
2 - when I change my jsp pages and try to reload them or shutdown the
server (by closing the window not using shutdown script) and startagain I
can not find my changes
I defined the CATALINA_HOME and JAVA_HOME VARIABLES .

JAVA_HOME = C:\JDK1.3
CATALINA_HOME = C:\tomcat4.0\jakarta-tomcat-4.0-b5
could you please help me to fix the problem
thank you

 
Meng Tan
Ranch Hand
Posts: 115
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
seems like there is a problem in your Catalina_home variable setting.
Try setting to "CATALINA_HOME = C:\tomcat4.0".
 
Ashik Uzzaman
Ranch Hand
Posts: 2373
Eclipse IDE Firefox Browser Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Or better download the Tomcat 4.0.1 version....can't rely on Beta, nah?
------------------
Muhammad Ashikuzzaman (Fahim)
Sun Certified Programmer for the Java� 2 Platform
--When you learn something, learn it by heart!
 
Kami Da Man
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Well although it seems stupid, but i m giving u an clue. u can try them. Hope this would work.
Dont write space before equalsto sign=) bcoz this space will be counted as part of the variable name e.g CATALINA_HOME=C:\Tomcat4 and CATALINA_HOME =C:\Tomcat4 are different environment variables. You can verify this by seeing check all the env. variables.
Secondly U should remove this xtra-long-Filename like Jakarta BlahBlah..just cut the directory as it is and paste it on the tomcat4 root directory.
One more thing for safe side..for the short cut of your batch file increase the memory by going into it properties(right click).

------------------
** KamiTheMan **
KamiDaMan@hotmail.com
 
Tim Duncan
Ranch Hand
Posts: 150
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Under Windows2000 environment vars can be set by right clicking on "My Computer", selecting "Properties" from the menu, then selecting the "Advanced" tab from the resulting pop-up, and "Environment Variables" from the tab. That way there's no worry about extra spaces, and you don't even need to reboot the machine (marvellous, how do they do it, these Microsoft chappies?)
There doesn't appear to be any problem with long directory names under Win2000, though I believe it may be under Win95/98.
CATALINA_HOME should point to the Tomcat directory which contains "bin", "conf", "lib", and "webapps" subdirectories.
Oh, and don't forget to add "tools.jar" from your JDK's "lib" dir to the CLASSPATH.

Oh, by the way, there is a naming policy which posters are expected to follow.


[This message has been edited by Tim Duncan (edited November 28, 2001).]
 
ramymoneiry4
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
thank you for your replies , it helps me to solve the first
problem when I delete the space in the dir name
but I am still can not solve the second problem which that I can not see the changes that I made to my jsp . i.e my jsp are not reloadable , my jsp files on the directory
webapps\myWebApplication
can you help me to fix the second problem
thank you
 
Carl Trusiak
Sheriff
Posts: 3341
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
ramymoneiry4
JavaRanch has a Naming Policy Please read it and register with a proper name.
Problem could be a cache problem with your browser. IE Tools - Internet Options Click the settings button on in the Temporay Files section. Choice the option to check for newer version on every visit to the page.
NS - Edit - Preferences click the + beside advanced select cache and ensure it's checked Every Time.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic