Win a copy of The Little Book of Impediments (e-book only) this week in the Agile and Other Processes forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

J2EE 1.2.0 vs J2EE 1.2.1 vs J2EE 1.3._01 vs J2EE 1.3.1

 
Kevin Thompson
Ranch Hand
Posts: 237
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Is anyone else here driven insane by the "what version works with what" phenomena?
I noticed that the Java Web Component Developer Exam is for JSP 1.2 and Servlets 2.3 (which are part of J2EE 1.3.1 (or J2EE 1.3_01)
But I don't understand the big picture.
Is it version J2EE 1.2 that includes version JDK 1.2(or JDK1.2.2) that goes with JSP 1.1 and Servlets 1.2 and EJB 1.1 that works with Tomcat 3.2.1 that is programmed using JBuilder 3.0 that works with BEA Weblogic 4.0 that is similar to IBM Websphere 5.0?
Or is it J2EE 1.3 that includes version JDK 1.3(or JDK 1.4) that goes with JSP 1.2 and Servlets 2.3 and EJB 2.0 that works with Tomcat 4.0.3 that is programmed using JBuilder 5.0(or JBuilder 6.0) that works with BEA Weblogic 5.0 that is similar to IBM WebSphere 6.0(or IBM WebSphere 7.0)?
Where is the cross reference to these versions? If J2EE 1.2 includes EJB 1.1, and J2EE 1.3 includes EJB 2.0, then what happened to EJB 1.2?
I found materials on Sun's site, but they were contradictory and not inclusive.
 
Axel Janssen
Ranch Hand
Posts: 2166
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Kevin,
I am not an expert on this, but I never run into problems, though I am programming with JSP1.1 and Servlets 2.2 or with JSP 1.2 and Servlets 2.3 and am playing around with EJB1.1 and EJB 2.0.

J2EE 1.2 runs on
Tomcat 3.x, IBM Websphere 4.0
includes:
- Servlets 2.2
- JSP 1.1
- EJB 1.1
J2EE 1.3 runs on
Tomcat 4.x, IBM Websphere 5.0, newest version of Weblogic
includes:
- Servlets 2.3
- JSP 1.2
- EJB 2.0
There is no EJB 1.2. EJB 1.1 --> 2.0 is quite a big jump with lots of new stuff. The change in Servlets, JSP is minor and more puntual (hope you have this word in english).
These are minimum requirements. You get only J2EE 1.3 if you have J2SE 1.3, but its possible that an J2EE 1.2 server is based on J2SE 1.3, though only J2SE 1.2.2 is necessary (I believe, might be wrong).
Correct me if I am wrong.
Axel
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic