Win a copy of The Business Blockchain this week in the Cloud forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Upgrading from tomcat3 to tomcat4

 
Chasee Lee
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi, I am getting this message when upgrading from tomcat3 to tomcat4:
"ERROR reading java.io.ByteArrayInputStream@61a408
At Line 33 /web-app/servlet-mapping/"
I guess there is an syntax error when the engine tries to read one of the web.xmls (in the conf and webapps\mycontex\web-inf). What should I do with it? Please kindly help!
 
Steve Guo
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I got that error too in Tomcat404, but I assume it is due to error in your web.xml.
For example, other people have said you can define multiple security role aliases, in
<security-role-ref>
<role-name>boss</role-name>
<role-name>mgr</role-name>
<role-link>manager</role-link>
</security-role-ref>
I found you cannot have multiple <role-name> tags
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic