Win a copy of The Java Performance Companion this week in the Performance forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

servlet problem- - weird

 
Munish Dabra
Greenhorn
Posts: 19
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hey dudes!
I can run all examples on Tomcat.but when i try to run my own servlets ,it is giving error with every servlet i m trying to run.I tried everything i cooldn't figure it out why itz happening.
I m using Apache Tomcat/4.1.29 and j2sdk1.4.2_02 on windows 200 server.
help me out...I m unable to proceed without this.

Error:
HTTP Status 404 - /myapp1/HelloWorld
--------------------------------------------------------------------------------
type Status report
message /myapp1/HelloWorld
description The requested resource (/myapp1/HelloWorld) is not available.

--------------------------------------------------------------------------------
Apache Tomcat/4.1.29
 
Brian Smith
Ranch Hand
Posts: 232
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi manas,
looks like "myapp1" is your context root. have you tried looking at your servlet mapping in web.xml file. Have you mapped your "HelloWorld" servlet in web.xml. i think you need to work on your web.xml file. you should be fine.
good luck
 
Ko Ko Naing
Ranch Hand
Posts: 3178
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Manas Dabra,
If u provide us with the desired servlet mapping name and ur real servlet location, then we can help u in mappng them in the web.xml deployment descriptor....
[ December 10, 2003: Message edited by: Ko Ko Naing ]
 
Manish Hatwalne
Ranch Hand
Posts: 2595
Android Firefox Browser Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Try
/myapp1/servlet/HelloWorld
HTH,
- Manish
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic