• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

need urgent help in runnin examples from hf jsp&servlet

 
Abhi Chat
Ranch Hand
Posts: 57
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Im trying to install tomcat 5 but it says jvm not installed..but when im tryin to install tomcat 4..it installs smoothly and it finds the jvm...could anybody help me on this???

Also im tryin to run the first program (example) from hf jsp&servlet book...i make a folder in tomcat/webapps/ch1/web-inf and put the class files and the DD as shown..but when when i try to run http:\\localhost\ch1\Serv1..it doesnt run...but this http:\\localhost\index.html works fine..

could anybody help me on this???
 
Colin Fletcher
Ranch Hand
Posts: 200
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The default installation of tomcat runs on port 8080...

You will need to look at the startup files for tomcat and adjust according to your specific install.
 
Abhi Chat
Ranch Hand
Posts: 57
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
ya i did that..actually i did

http:\\localhost:8080\ch1

does not work..any idea which startup files need to be changed.....
 
Sharon
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
have you start tomcat without any error message? I tried with error while startup tomcat with suggested web.xml heading. Everything run fine except this.
 
Abhi Chat
Ranch Hand
Posts: 57
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
ya tomcat has started smoothly.....still im not able to run things down.....
 
Sharon
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
according to Al Skylar's instruction, Tomcat 4 does not support Servlet 2.4 but only Tomcat 5.
refer to ---> http://www.coderanch.com/t/168294/java-Web-Component-SCWCD/certification/HFS-first-exercise
 
Abhi Chat
Ranch Hand
Posts: 57
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
thanx guys.....the problem is fixed..actually tomcat doesnt support 2.4 specification....(as u guys discussed)....ill get tomcat 5

 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic