• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Tomcat 5.0 and 5.5

 
James Turner
Ranch Hand
Posts: 194
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Guys,

I am quite new to the SCWCD exam although I do use Servlets and JSP at work. I have recently started to study for it.

I downloaded Tomcat 5.5 as I believe this is the lasted version. To my understanding Tomcat 5.5 is for J2SE 5.0 and Tomcat 5.0 is for J2SE 1.4.

I have got both J2SE 5.0 and J2SE 1.4.2 installed but I am having trouble running Tomcat 5.5. It works but applications I have deployed don't seem to work. With 5.0 they work.

Has anyone else had any problems with 5.5 or am I doing something wrong. I know that Tomcat 5.5 is working with J2SE 5.0 and Tomcat 5.0 is working with J2SE 1.4.2 on my machine. So it's not that they are running though the wrong JVM versions.

Anyone have any comments on Tomcat 5.5 as oppose to Tomcat 5.0? Which one is the one I should use? Are there any differences in the Tomcat code from 5.0 to 5.5 other then compatibility issues with J2SE 5.0 and J2SE 1.4?

Thanx for any help...

Regards,

James.
 
Mike Curwen
Ranch Hand
Posts: 3695
IntelliJ IDE Java Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I would stick with 5.0. 5.5 is very new (it's actually 5.5.4 by now, I think). Whereas 5.0 is up to 5.0.30.

There are a number of configuration differences between the two.

There is no difference in the version of the spec that 5.0 and 5.5 support, so for purposes of studying for SCWCD, I'd stay with 5.0
 
Gaurav Sahni
Ranch Hand
Posts: 56
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Has anyone else had any problems with 5.5 or am I doing something wrong.



i checked Apache Website just now. Infact, Tomcat 5.5 is released yesterday only (3rd Dec). So the likelihood of somebody having tried it is v.less.

Being in its incubatory state, it is recommended to play safe and use tomcat 5.0.X, till we get some results on the new version.

As Mike has said, there is no difference in the version of the spec that 5.0 and 5.5 support.

Happy developing...
Gaurav.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic