• Post Reply Bookmark Topic Watch Topic
  • New Topic

Servlet JSp error page problem in IE

 
A Garg
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I am facing strange problem while using Internet Explorer 6 with Sp1

I have configured a error page for my web application as follow.

---------------------------------
<!-- web.xml file enteries -->

<error-page>
<error-code>404</error-code>
<location>/jsp/notFound.jsp</location>
</error-page>
<error-page>
<error-code>500</error-code>
<location>/jsp/500Error.jsp</location>
</error-page>
-----------------------------------

While application displays appropriate error page in Mozilla Firefox 1.0 and Netscape 7.2 it doesn't work in Internet Explorer 6 sp1 (it displays standard 500 or 404 error page )

Please tell me if someone else is also facing same problem.

Thanks,
Anil
[ February 11, 2005: Message edited by: A Garg ]
 
Mike James
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have my web.xml file configured almost identically to yours and have had no troubles with IE6 sp2.

My web.xml error page code is as follows:



I don't have a copy of IE6 sp1 for testing. Have you tried sp2 with your system?
 
Deb Sadhukhan
Ranch Hand
Posts: 67
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Should not behave this way. Hope you put the web.xml under correct application directory. Also you have restarted the server after that. Lot of servers will not pick up DD changes otherwise.
 
Gravity is a harsh mistress. But this tiny ad is pretty easy to deal with:
the new thread boost feature: great for the advertiser and smooth for the coderanch user
https://coderanch.com/t/674455/Thread-Boost-feature
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!