Win a copy of The Little Book of Impediments (e-book only) this week in the Agile and Other Processes forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

encodeURL() ony first time or what the ....?

 
Ner min
Ranch Hand
Posts: 76
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi, in my servlet(mycompanyS1) in the doGet
i have this simple test:


1 call produce
url=/mycompanyS1
linkvalue1=url=/mycompanyS1;jsessionid=F7C2ECC5CBCC76B333BDF5676B14E877
2 call (with a click on the link) produce
url=/mycompanyS1;jsessionid=F7C2ECC5CBCC76B333BDF5676B14E877
linkvalue1=/mycompanyS1
3 call (with a click on the link)and all others produce
url=/mycompanyS1
linkvalue1=/mycompanyS1

why is this ";jsessionid=F7C2ECC5CBCC76B333BDF5676B14E877" showing only first time on the link and first time in the url (wenn called through link)
but not on subsecuentt calls? and how comes that my session.getAttribute
functioning despite the fact that on subsecuent calls no urlRewriting happens?
i simply don't understand. my cookies in IE r disabled
Can someone explan me this?
tia nermin
 
Jeremy Leong
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I've tried you code out and I think I encountered a similar problem to yours. I believe it has to do with getting IE to not accept cookies from requests to host on your local intranet.

As far as I can tell, IE only lets you block cookies on sites in its 'Internet Security Zone', and that is what you're modifying in the "Internet options->Privacy tab" of IE. This does not apply to any sites that are in the "Trusted" & "Local Intranet" zones.

In order to block cookies from local services, you need to configure the "Local Intranet" zone. You can do that in the "Internet options->Security tab" by selecting "Local Intranet" and clicking "sites". From there, you can uncheck the first option which will put all localhost/intranetwork access in the "Internet Zone" and only then can you block cookies.

I did this and IE played nice and worked as it should have.
[ September 28, 2005: Message edited by: Jeremy Leong ]
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic