• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Using JSTL

 
Yati Tan
Ranch Hand
Posts: 56
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all, I need some help regarding JSTL. I have copied jstl.jar file in my application/WEB-INF/lib directory. Still Iam getting error in compiling JSP file while Iam including it as :

<%@ taglib uri="http://java.sun.com/jsp/jstl/core" prefix="c" %>

Pls help
 
Yati Tan
Ranch Hand
Posts: 56
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I got the answer myself. I didnot copied standard.jar file with jstl.jar file. Code is working now !!
 
Stein Vom
Ranch Hand
Posts: 78
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am asking for myself. Did you made any entries in web.xml?
In my case, it is showing these errors. Although i have copied the jstl.jar file in WEB-INF/lib folder.

org.apache.jasper.JasperException: 絶対URI: http://java.sun.com/jsp/jstl/core はweb.xmlまたはこのアプリケーションを配備したJARファイルのどちらかでも解決できません
at org.apache.jasper.compiler.DefaultErrorHandler.jspError(DefaultErrorHandler.java:105)
...
 
Yati Tan
Ranch Hand
Posts: 56
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I hv copied standard.jar along with jstl.jar. Nothing more to check. Yea, web.xml shud also be checked for this :

<web-app xmlns="http://java.sun.com/xml/ns/j2ee"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://java.sun.com/xml/ns/j2ee http://java.sun.com/xml/ns/j2ee/web-app_2_4.xsd"
version="2.4">

Also, check that you r running the same version of web.xml & jar files.
 
Stein Vom
Ranch Hand
Posts: 78
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks for the reply. I copied that text as you said, but the problem is still there. Now the page is showing

'The requested resource ... is not available.'

My web.xml has this entry in the beginning:

<?xml version="1.0" encoding="ISO-8859-1"?>

<!DOCTYPE web-app
PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.3//EN"
"http://java.sun.com/dtd/web-app_2_3.dtd">

Does anything (version) from that is creating any problem?
Please help.
 
Yati Tan
Ranch Hand
Posts: 56
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
U hv been using old version of Servlets I suppose. Please check that u hv the latest versions for the exam.
 
Stein Vom
Ranch Hand
Posts: 78
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The problem could be that i'm using older version of Tomcat: Tomcat 4.1 !!
Thanx anyway
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic