Win a copy of Functional Reactive Programming this week in the Other Languages forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

how to run tomcat in windows?

 
kuturam chakraborty
Greenhorn
Posts: 25
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi friends,


i have installed tomcat5.5 in windows xp ,now i am not being able to start it up.whenever i click on the tomcat monitor ,it says that an instance of tomcat is already running.also,please tell me how to set the environment variables in windows xp(professional)
 
Christophe Verré
Sheriff
Posts: 14691
16
Eclipse IDE Ubuntu VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
it says that an instance of tomcat is already running

It says it all, doesn't it ? You have another instance already running. If running as a service, stop it.
Or you can uninstall any previous version if you don't need it anymore.
 
Edisandro Bessa
Ranch Hand
Posts: 584
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The same happened to me in the first time I installed Tomcat.

By default, Tomcat enables itself as a Windows Service. So, you can either disable it to manually run whenever you want or keep the things as is.
[ June 20, 2006: Message edited by: Edisandro Bessa ]
 
kuturam chakraborty
Greenhorn
Posts: 25
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi Edissandro,

thanx for the reply,but in hfsj book ,while building the model mvc tutorial,they have given commands to shutdown tomcat,but when i try them from my command promt,it says "shutdown.sh" is not recognized as any command or batch file. is it because it is applicable only on linux\unix\osx?

how do i stop tomcat5.5 in windows xp?
 
Edisandro Bessa
Ranch Hand
Posts: 584
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
If Tomcat is running as a windows service :

Go to Administrative Tools and look for services option, there you can find Tomcat Service. Just right click it and choose stop.
 
kuturam chakraborty
Greenhorn
Posts: 25
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi edissandro, i did what you told,however in the admin tools->services option
it shows that tomcat is not running,should i install tomcat once again.
 
Cai DongShan
Ranch Hand
Posts: 102
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
1. Tomcat 5.5 requires JRE 5.0 by default. Did you installed Java 5 before installed Tomcat?
2. Did you start Tomcat service? Any error?
3. Try http://localhost:8080/. If tomcat page is shown, that means your tomcat works fine.
 
Sathish Nagappan
Ranch Hand
Posts: 76
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
For a windows installation , Tomcat automatically installs something called as Monitor. That will be present in your taskbar all the time. You can right click that and choose stop.
Install JRE for tomcat to work and set the path to the JRE like this:

Right click the monitor on the taskbar and click Configure, once you click that , choose Java {tab} and type in the path of the JRE there (If it is not automatically set the first time).

In the rare case that you dont see the monitor on the taskbar , Click on Start Menu > Programs > Tomcat > Monitor. This entry will only be there in your Start Menu if you have downloaded the Tomcat Executable.
 
kuturam chakraborty
Greenhorn
Posts: 25
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi aswanth,

inside the java tab,two path names are given,

1)java virtual machine
here the path name given is

C:\Program Files\Java\j2re1.4.2_07\bin\client\jvm.dll

and 2)java classpath where the path is

C:\Program Files\Apache Software Foundation\Tomcat 5.5\bin\bootstrap.jar

should i change anything here?

if i keep them ,i am not being able to start tomcat,there is a start tab but after clicking it it is not being able to start the app.

thank you all in advance
 
Cai DongShan
Ranch Hand
Posts: 102
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You should install Java 5. Or change Tomcat to 5.0.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic