Win a copy of The Little Book of Impediments (e-book only) this week in the Agile and Other Processes forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

TOMCAT not working - help required

 
Atul Sawant
Ranch Hand
Posts: 304
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi guys,

I have just started programming servlets and jsp using HFSJ. I tried to install Tomcat 5.23 (with servlets 2.4 and jsp 2.0 specs) and then it was asking for J2SE 5 JRE.

I have Windows 98 and i am using jdk1.4. When it asked for J2SE 5 JRE. i gave it path of jdk1.4 to complete installation. It completed the installation with a small error which i ignored and after tha when i tried to open the tomcat.exe. It is not working.

I am not sure how exactly i do and i need to do for installiong Tomcat and make that thing working! I am stuck in chapter 3 and i need to go ahead really fast.

Please help!

Atul
 
Leena Diwan
Ranch Hand
Posts: 351
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Im not sure what error you got but as per my knwoledge, you should get this clear message in the console that with TOMCAT 5[and above] you need JDK1.5

If not, i.e if you need to use jdk1.4.x itself then there is one compatibility path available. Search on google for this 'compatibility patch' and you should get it.

Regards,
Leena
 
Atul Sawant
Ranch Hand
Posts: 304
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks a lot Leena.

I tried to download the jdk1.5 from sun but it was giving me "Page cannot be displayed" when i clicked on the download button.

Is there any other source where i can download the stuff or Is there any other tool/server like Tomcat which I can use?

Thanks a lot for your help!
Atul
 
Atul Sawant
Ranch Hand
Posts: 304
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello guys...

Someone could please answer my question...

Thanks in advance.
Atul
 
Christophe Verré
Sheriff
Posts: 14691
16
Eclipse IDE Ubuntu VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Tomcat 5.5 is designed to run on J2SE 5.0 and later, and requires
configuration to run on J2SE 1.4. Make sure to read the "RUNNING.txt"
file in the fulldocs downloadable file(s) if you are using J2SE 1.4.

You'd better download 5.0 though. Can't you access the following page ?
http://java.sun.com/javase/downloads/index_jdk5.jsp
and get JDK 5.0 Update 11 (don't forget to select the "Accept" radio button)
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic