Win a copy of Functional Reactive Programming this week in the Other Languages forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Tomcat showing error

 
Joe Harry
Ranch Hand
Posts: 10124
3
Eclipse IDE Mac PPC Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Guys,

I have a tomcat installation on port 7080 and when I try to access it using http://localhost:7080, I'm getting 5 squares in the response of my webpage. What could the problem be?? I'm guessing some response content type is not proper. Where can I set the response types for Tomcat server itself??? Please help guys!
 
Joe Harry
Ranch Hand
Posts: 10124
3
Eclipse IDE Mac PPC Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm not understanding this. Is there any mime-type setting for the Tomcat server as such??
 
Priya Viswam
Ranch Hand
Posts: 81
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You can configure mime types in tomcat. Please check the file web.xml in the conf folder of tomcat.
 
Rahul Bhattacharjee
Ranch Hand
Posts: 2308
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I think the problem is with the encoding.Browser is getting bytes of some different code page and not able to convert those and ending up with square boxes.Try setting encoding along with the mime in response header.
 
satya mahapatra
Ranch Hand
Posts: 134
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Try on port 8080. It may work.
 
Joe Harry
Ranch Hand
Posts: 10124
3
Eclipse IDE Mac PPC Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Priya,

I checked the web.xml in the conf folder of tomcat and set the mime-type correctly. Here is the part of that web.xml file from the conf folder of tomcat,



I'm getting "application/octet-stream" as the response when I request for the resource. If you see the italicized part in the file above, you will find "application/octet-stream" and I'm getting this as the response...

[ May 02, 2007: Message edited by: Jothi Shankar Kumar Sankararaj ]
[ May 02, 2007: Message edited by: Jothi Shankar Kumar Sankararaj ]
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic