Win a copy of The Little Book of Impediments (e-book only) this week in the Agile and Other Processes forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

J2EE 1.4

 
Jeff Schuler
Greenhorn
Posts: 23
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I take it I should be using J2EE 1.4 when preparing for this exam. Will J2EE 1.5 be fine as well when studying for this exam? Why does the Head First book tell me to install J2SE 1.4? Sorry about the newbie question but I'm unfamiliar to 'EE'.

Is it ok to both have JSEE 1.4 and J2SE 6 installed on the same Windows machine? I presumed I will just need to setup the classpath to point to the J2EE 1.4 version when preparing for this exam.
 
Christophe Verré
Sheriff
Posts: 14691
16
Eclipse IDE Ubuntu VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Will J2EE 1.5 be fine as well when studying for this exam?

If you set everything to use servlets 2.4 and JSP 2.0, then it will be fine.
However, you should stick to 1.4 if possible.

Why does the Head First book tell me to install J2SE 1.4?

You need J2SE 1.4 to compile your servlets. Your web container will also need it.

Is it ok to both have JSEE 1.4 and J2SE 6 installed on the same Windows machine?

When studying for SCWCD, you should not need the complete J2EE, because you'll be studying only the web part of J2EE.
Only J2SE and a web container will do. For example : J2SE1.4 and Tomcat 5.5.x
[ August 19, 2007: Message edited by: Christophe Verre ]
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic