Win a copy of The Little Book of Impediments (e-book only) this week in the Agile and Other Processes forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

EL/Tag file question

 
Ste Graham
Greenhorn
Posts: 23
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi - I'm following the example in chpt17 of the Manning SCWCD exam guide, but I just cannot get it to work. I have two files:

1. example.tag


2. example.jsp


When I access example.jsp from the web browser I get the following output:


I just cannot understand why the fibnum variable is not interpolating correctly - am i missing something?
 
Michael Ku
Ranch Hand
Posts: 510
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
It looks like the EL is not activated in your web container
 
amit punekar
Ranch Hand
Posts: 544
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello,
Another reason could be that your web.xml version may be 2.3. I have experienced similar problem when working with EL on tomcat 5.x with JDK1.4. I modified the web.xml to conform to version 2.4 and then EL worked.
thanks
amit
 
Christophe Verré
Sheriff
Posts: 14691
16
Eclipse IDE Ubuntu VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Your web.xml should be configured like this.
And the taglib uri should be like this.

(I wish you good luck to study tag libraries with Manning's study kit)
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic