Win a copy of Functional Reactive Programming this week in the Other Languages forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

EL Not working

 
Deepak Chopra
Ranch Hand
Posts: 433
Eclipse IDE Firefox Browser Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I am using Oracle JDeveloper 10G and EL expressions are not working on this? Why is that so ?
Following is my code :

Output is :

Hi My Name is is...${person.name}
What can i do to correct this?
[ March 28, 2008: Message edited by: Sunny Jain ]
 
Christophe Verré
Sheriff
Posts: 14691
16
Eclipse IDE Ubuntu VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Check the web-app tag of your web.xml. The instructions are in this FAQ.
 
Deepak Chopra
Ranch Hand
Posts: 433
Eclipse IDE Firefox Browser Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Christophe Verre

I have following mentioned in the web.xml :


How to correct this..? I saw that jstl.jar's version is 1.0. I have download the jstl.jar version 1.2 ; but dont know where should i replace this, I look into the WEB-INF folder, there is not lib folder there..!! I am confuse..
 
Christophe Verré
Sheriff
Posts: 14691
16
Eclipse IDE Ubuntu VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
web-app_2_3.dtd

Can't you use 2.4 instead ? This forum is for SCWCD. You should be using at least 2.4.


<web-app xmlns="http://java.sun.com/xml/ns/j2ee"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://java.sun.com/xml/ns/j2ee http://java.sun.com/xml/ns/j2ee/web-app_2_4.xsd"
version="2.4">


EL is disabled by default in 2.3
[ March 28, 2008: Message edited by: Christophe Verre ]
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic