• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Jeanne Boyarsky
  • Junilu Lacar
  • Henry Wong
Sheriffs:
  • Ron McLeod
  • Devaka Cooray
  • Tim Cooke
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Frits Walraven
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Piet Souris
  • salvin francis
  • fred rosenberger

Question on SDK1.3 Installation

 
Ranch Hand
Posts: 183
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Now going back to "chapter 1". After finishing installing the SDK 1.3 in Window ME, I notice that the path is missing c:
jdk1.3\bin. Without this path, I cannot simply run rmiregistry, but have to provide the full path like c:\jdk1.3\bin\rmiregistry. Now, I have two questions:
1) Strangely enough, if the full path is provided for running rmiregistry, i.e. start c:\jdk1.3\bin\rmiregistry, my server program will throw a remote exception upon calling up the Naming.rebind(). It says "RemoteException occurred in server thread; nested exception is: java.rmi.UnmarshalException: error unmarshalling arguments; nexted exception is: java.lang.ClassNotFoundException: server.RemoteRequestImpl_Stub".
However, this problem will not happen, if I supply the path name c:\jdk1.3\bin to autoexec.bat, and then directly execute start rmiregistry. Any idea? Perhaps, you can try it out yourself and see if you have the same problem.
2) do we need to mention that the path c:\jdk1.3\bin have to be added in our document?
 
Thanks tiny ad, for helping me escape the terrible comfort of this chair.
Devious Experiments for a Truly Passive Greenhouse!
https://www.kickstarter.com/projects/paulwheaton/greenhouse-1
    Bookmark Topic Watch Topic
  • New Topic