• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Jeanne Boyarsky
  • Junilu Lacar
  • Henry Wong
Sheriffs:
  • Ron McLeod
  • Devaka Cooray
  • Tim Cooke
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Frits Walraven
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Piet Souris
  • salvin francis
  • fred rosenberger

Can't show my name/remote object bindings

 
Ranch Hand
Posts: 41
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am using the LocateRegistry to create registry in the server and get registry reference in my client app. (I did not use web server for my testing)
My rmi works fine when files are placed in a Client folder and Server folder. They are also working when I add a download folder using the dynamic class loading.
But when i try to show my current binding of my registry. Nothing is shown and as if there is no binding at all.
Server:
<<using local host and default port>>
Registry reg = LocateRegistry.createRegistry() ;
reg.rebind("RemoteDbObj", remoteObj);
String [] = reg.list();
print String[]............
Client
Registry reg = LocateRegistry.getRegistry();
reg.list();
print String []............
In both server and client...no binding is shown..
Can anyone explain me why ?
 
I have gone to look for myself. If I should return before I get back, keep me here with this tiny ad:
Devious Experiments for a Truly Passive Greenhouse!
https://www.kickstarter.com/projects/paulwheaton/greenhouse-1
    Bookmark Topic Watch Topic
  • New Topic