posted 14 years ago
Just wanted to get peoples' opinions on naming classes. This is really the first project that I have actually thought out the patterns before starting the project and I have since been naming my classes after the patterns (ex: FBNFacade, FBNModel, FBNView, FBNController, etc...). This really doesn't tell the user/maintainer much about what the class does... what do ya'll think? Should I change the classes to have more meaningful names?