• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Question regarding version of JDK to use?

 
Saheed Adepoju
Ranch Hand
Posts: 267
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all
I was wondering, has J2SE 5.0 superceeded J2SE 1.4.2 by 18 months. I see all over the forum that some people have started translating their already existing code unto the new platform! And pls if you do transform your code would you have to use the new features of "Tiger" for your programming assignment. I intend to download probably march. Thanks for all your response.
Saheed
SCJP 1.4
SCJD 1.4(maybe 1.5){Preparing..).
 
Robert Konigsberg
Ranch Hand
Posts: 172
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
It has not be 18 months since 1.5 was introduced. This post from James Gosling suggests it was released in September '04:

http://today.java.net/jag/page12.html#100
 
Andrew Monkhouse
author and jackaroo
Marshal Commander
Pie
Posts: 12007
215
C++ Firefox Browser IntelliJ IDE Java Mac Oracle
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Saheed,

According to the Sun site for J2SE Code Names, J2SE 5.0 was released on Sept 29, 2004. This implies that you can still use J2SE 1.4 until Mar 29 2006.

Regards, Andrew
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic