Win a copy of The Little Book of Impediments (e-book only) this week in the Agile and Other Processes forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

All my records are deleted ?

 
Mihai Radulescu
Ranch Hand
Posts: 918
IntelliJ IDE Java Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hallo,

I have the URLyBird 1.3.3 and now I am working on the data access layer.
I have a first prototype and I do some read tests.My database file contains 29 records but all are invalid, the valid falg (for all) is 0.

0 implies valid record, 0xFF implies deleted record.

Is this normal ?
 
Uwe Schäfer
Ranch Hand
Posts: 52
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Mihai Radulescu:
My database file contains 29 records but all are invalid, the valid falg (for all) is 0.

0 implies valid record, 0xFF implies deleted record.

Is this normal ?


...rubbing my eyes... so, in contrast to the thread�s title, all your records are valid, right ? i cannot see no problem then .
i have an urlybird and face the same situation.
[ June 14, 2005: Message edited by: Uwe Sch�fer ]
 
Mihai Radulescu
Ranch Hand
Posts: 918
IntelliJ IDE Java Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Uwe,

Opps, my mistake all my records are invalid(the valid flag is 0).
How is on you (Uwe)?

All are valid or all are invalid ?
 
Uwe Schäfer
Ranch Hand
Posts: 52
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Mihai Radulescu:

all my records are invalid(the valid flag is 0).


... rubbing eyes again ...

your interpretation of a record being INvalid when valid flag is 0 seems to contradict the clear statement from the assignment you quoted:
'0 implies valid record, 0xFF implies deleted record.'

so i suppose all your records are valid and so are mine
 
Mihai Radulescu
Ranch Hand
Posts: 918
IntelliJ IDE Java Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Oh, you're right!!!
I had a copy/paste problem.I retuned the same flag value 0 for both fags(valid/delete).

Thanks !!!
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic