• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Can i write ?

 
Chandrasekhar Mangipudi
Ranch Hand
Posts: 118
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi , Java Ranchers. Can i write scjd in 1. 5 version.
Sekhar(scjp 1.4).
 
Jeroen T Wenting
Ranch Hand
Posts: 1847
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
no, you MUST use 5.0.
It's been out for more than 18 months, so 1.4 is no longer allowed.
 
Andrew Monkhouse
author and jackaroo
Marshal Commander
Pie
Posts: 12007
215
C++ Firefox Browser IntelliJ IDE Java Mac Oracle
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Since Jeroen's post confused me (event though he is correct), I thought I'd clarify:

Both version numbers "1.5.0" and "5.0" are used to identify [the same] release of the Java 2 Platform Standard Edition.

So to answer your question: yes, you can use JDK 5 (or JDK 1.5 if you prefer that nomenclature).

But Jeroen is also correct: it is not a case of whether you can or not, but a case of you must use JDK 5 / JDK 1.5.

Regards, Andrew
 
Barry Gaunt
Ranch Hand
Posts: 7729
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
... and you can do it with SCJP 1.4, you don't need to upgrade to SCJP 5.
I hope that covers all possibilities
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic