Win a copy of The Little Book of Impediments (e-book only) this week in the Agile and Other Processes forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Java 1.4 or 5.0

 
L Yan
Greenhorn
Posts: 18
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello,

I am new at SCJD. And I am reading a SCJD book said the Java version you use in SCJD must not older than 18 months. Does it meant that we must use Java 5.0 to program the assignment? In Sun's official website, I only found that Sun Certified Developer for Java 2 Platform, but it doesn't talk about which version.

Thank you all.
 
Thirumurugan Mylrajan
Ranch Hand
Posts: 64
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You must use 1.5. The valid date for j2se v 1.4 expired some time in march I guess.

Anyway code developed in 1.4 will mostly compile and run fine in 1.5 . But may give some additional warnings, I guess.

Thanks.
 
Jeroen T Wenting
Ranch Hand
Posts: 1847
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
yes, 5.0 is now the only allowed version.
And I'd make sure everything compiles without warnings at the strictest compiler level.
Might not be strictly necessary, but why take chances?
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic