Win a copy of The Little Book of Impediments (e-book only) this week in the Agile and Other Processes forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Which JDK is OK for the 1.4 SCJP certificated people?

 
josine wilms
Ranch Hand
Posts: 45
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Which JDK is OK for the 1.4 SCJP certification?

I got the SCJP 1.4 a few months ago.
Now I read in the SCJD FAQ that since March 29, 2006 I should use JDK 1.5 for the SCJD assignment ...
But don't I need in that case as a prerequisite SCJP 1.5...?


SCJD FAQ:
Example calc: 1.5.0 was released on Sept 29, 2004, superseding 1.4.2. However you can still use 1.4.2 until it has been superseded by 18 months, so adding the 18 months to Sept 29, 2004 means that you can still use 1.4.2 until March 29, 2006.

Thanks and success all,
Josine
 
Anne Crace
Ranch Hand
Posts: 223
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You don't need SCJP 1.5 to do SCJD. But I would use Java 1.5 to do my SCJD project. I believe you are correct in that you can still use 1.4 if you complete within that timeframe. I would just bite the bullet and use 1.5. Main changes are enhanced "for" loop and generics, which are actually pretty cool once you know how to use them. Good luck.
 
josine wilms
Ranch Hand
Posts: 45
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Anne,

Thanks for your answer.
 
Barry Gaunt
Ranch Hand
Posts: 7729
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The deadline has passed. You must use Java 5.0.
 
Mihai Radulescu
Ranch Hand
Posts: 918
IntelliJ IDE Java Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,People

IMHO you can use any java2, (the exam is Sun Certified Developer for the Java 2 Platform), java 1.4 is java2.
If your compilable with 1.4 you can do it with 1.5 also. I start my project with 1.4 and I switch to 1.5 later without any problem(o.k I do some changes for the genrics, in/outboxing, etc).

To use 1.5 means that your code must be compilable with 1.5.


Regards M
[ August 07, 2006: Message edited by: Mihai Radulescu ]
 
Jeroen T Wenting
Ranch Hand
Posts: 1847
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
No, you MUST use 1.5. Not sure if they do, but if I were an assessor I'd check the classfile version of your submission to see if an allowed compiler was used.

It should also not just compile but compile without any warnings at the strictest compiler settings.
Maybe not a strict requirement, but good practice and impossible to do with an older compiler as some things that now throw compiler warnings are impossible to prevent in code that will compile with older compilers.
 
Mihai Radulescu
Ranch Hand
Posts: 918
IntelliJ IDE Java Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Ok when I say "code must be compilable with 1.5" I mean also compile without any warnings.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic