Win a copy of The Little Book of Impediments (e-book only) this week in the Agile and Other Processes forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Which version of Java SE for SCJD

 
Mahendran Mohan
Greenhorn
Posts: 11
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi everyone, I need a small clarification on the java version i should use for my SCJD project. I believe Java SE6 was released by Dec-2006, so going by scjd's "18 months old version" rule i should only use Java SE6 and not Java SE 5. Please correct me if i am wrong.

Projects on SCJD should not be done on SE5 anymore. Although difference in version might not come in way, but still want to get it confirmed. Apprecciate if anyone can confirm whether it is ok to do project in SE5.


thanks in advance, Mahendran
 
Ulf Dittmer
Rancher
Posts: 42969
73
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Welcome to JavaRanch.

It is not OK; you need to use Java 6. Of course, you can develop it on an earlier version, but you need to ensure that it runs on the latest.
[ September 24, 2008: Message edited by: Ulf Dittmer ]
 
Jeffry Kristianto Yanuar
Ranch Hand
Posts: 759
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
For your safety, just use the latest version of Java SE version.

Jeffry Kristianto Yanuar (Java Instructor)
SCJP 5.0, SCJA, SCJD (Working on UrlyBird 1.3.2) --> preparing to upload
 
Mahendran Mohan
Greenhorn
Posts: 11
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
thanks to both of you.

Cheers, Mahendran
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic