• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Multiple JREs

 
Burk Hufnagel
Ranch Hand
Posts: 814
3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
As I understand it, one of the features of Web Start is that you can tell it which version of the JRE your app needs and web Start will install it for you.
This sounds pretty good at first, but then I had to wonder whether that's necessary. If I specify JRE 1.2 and you already have 1.3 installed then do you really need 1.2? The app should be fine under 1.3, and I'm concerned about the possible proliferation of JREs on a single users machine.
Comments?
Burk
 
Madhav
Greenhorn
Posts: 11
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi burk,
It's true that webstart's been used for installing latest versions and JRE.If one has JRE1.3 and is trying to install an application that works on JRE1.2 it's ok .If it is the other way round one should have to use webstart.We used webstart for our application and we had 2 links on the webstart install latest version(of application) page.One is for JRE(if one dose not have a correct JRE) and the other one is for latest version on application.I think option for JRE is not a over head and it is useful too.
what do u say?
regards,
madhav
 
Mark Herschberg
Sheriff
Posts: 6037
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Burk Hufnagel:

This sounds pretty good at first, but then I had to wonder whether that's necessary. If I specify JRE 1.2 and you already have 1.3 installed then do you really need 1.2?

But if you have 1.2 and need 1.1.8, you'll need to install 1.1.8.
--Mark
 
mukund kulkarni
Greenhorn
Posts: 23
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
There is a way to solve the above problem
you can mention jre version as 1.2+
first JWS will look for the exact version if it doesn't found the same then it will go for the next higher version available onb the machine.
This way you can make sure that the it will work even if the client has jdk1.3 installed on machine
-mukund
[ April 16, 2002: Message edited by: mukund kulkarni ]
 
Burk Hufnagel
Ranch Hand
Posts: 814
3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Okay, so if I say I need 1.2+ then as long as you already got 1.2 or higher it won't install another JRE.
Cool. Thanks for the info!
Burk
 
Mauro Marinilli
Author
Greenhorn
Posts: 27
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Guys,
Remember that (due to its inner working mechanism based on the dynamic classloader feature) JNLP works only with J2SE! So you cannot specify "1.1.8" because that is not Java 2. But you can say "1.4+", for instance.
Cheers,
Mauro
 
Burk Hufnagel
Ranch Hand
Posts: 814
3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
"only works with J2SE"
So I can't use Web Start to install parts of a J2EE application then?
I wouldn't normally thought about this, but the above phrase made me wonder if it woulnd't be a nice thing to use Web Start to update the JAR files in a Web Application.
Anybody know of an easy way to do it?
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic