Win a copy of The Little Book of Impediments (e-book only) this week in the Agile and Other Processes forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

java web start (jre) incompatibilities

 
igwe kalu kalu ogba
Ranch Hand
Posts: 133
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi, I've written a jar file using the java jdk 1.5, but most of the programs that will be running it will be using jdk 1.4.2 or thereabouts. Now I tested this program through jnlp on a machine with jre 1.4.2 and it almost worked, but when it got to starting application, it simply froze. However, as soon as I installed jre 1.5 it started working. I'd like to know if theres a solution to this problem, do I have to install jre 1.5 on every machine?? This will be very tedious as there are hundreds of machines in the office. Or should I recompile the program with jdk 1.4.2?? please help. thanks.
 
igwe kalu kalu ogba
Ranch Hand
Posts: 133
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
OK I've thought about something, in my JNLP file I specify in the j2se tag:

<j2se version="1.5+"/>

apparently I can equally say

<j2se version="1.5+" href="tomcat-server"/>

Now, I'm hosting a copy of jre1.5 on my tomcat server and I've specified that jre download from there, but it doesnt seem to work. The file I'm hosting is : jre-1_5_0_01-windows-i586-p.exe.

But when I comment out the attribute leaving only version, after launching the jnlp file, it automatically finds it's way to the javasoft website and tries is quite successful in downloading jre 1.5. My question is this, is there a way I can set in the jnlp file to download jre 1.5 from my lan machine instead of going to javasoft. this is because the internet connection at my office can be excruciatingly slow and therefore I feel a lan download will be better and faster. Thanks a lot.
 
Shaun Appleton
Greenhorn
Posts: 21
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I don't think this is going to work as you compiling using a Java 5 JDK and trying to run it in a 1.4.2 JVM. Binaries are not backwardly compatible. See http://java.sun.com/j2se/1.5.0/compatibility.html#binary

Shaun
 
Jared Cope
Ranch Hand
Posts: 243
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I agree that you will run into problems trying to run an app built with 1.4 version of Java, and then run in 1.5 JRE (or vice-versa). I've recently been through this and if the application does actually load up, little things have changed between the two.

However, you can specify to load the install program for 1.5 from your local server. You will need to consult the .jnlp file syntax but here is a starting point.

http://www.vamphq.com/jwsfaq.html#ownj2se

I must confess, I've not actually tried to do it though.

Good luck, Jared.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic