• Post Reply Bookmark Topic Watch Topic
  • New Topic

login fails

 
prahlad surapaneni
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
In our application, we have LoginAction.java class. when the application is running on QC server for testing 5% of logins are failing. When we check for the code, it is fine. In the testing 100 users are trying to login per second and approxmately 5 users can't able to login. When 200 users are tried, nearly 10 are failed. And we are not getting any failed messages like network or server problem or database problem or anything.

if you have any idea of this please let me know the problem(s).

Thanks
Prahlad
 
Ernest Friedman-Hill
author and iconoclast
Sheriff
Posts: 24213
35
Chrome Eclipse IDE Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

Welcome to JavaRanch!

We have a strict policy on display names, which must be a real first and last name with a space between.

Please go here and fix your display name up, pronto. Thanks, pardner!
 
Ernest Friedman-Hill
author and iconoclast
Sheriff
Posts: 24213
35
Chrome Eclipse IDE Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks for fixing your display name.

Now, let's see. You say there are no error messages or anything. In what way do the logins fail -- i.e., what are the symptoms of the failure?

You might want to describe your setup -- what OS, what app server, what database, etc -- as these might be helpful to someone in advising you.
 
steve souza
Ranch Hand
Posts: 862
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
That isn't much info for us to help you with. I suspect if the login is failing due to a db problem it should show up as a Connection problem. If you use the jamon jdbc driver you will see if any exceptions are being thrown in your jdbc code.

http://jamonapi.sourceforge.net/#WhatsNew22

Do you have any custom code that gets executed as part of the login? That might be failing too.
 
prahlad surapaneni
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

Thanks a lot for your replies. We found a problem with in our message server. We are trying to fix it.If any more I will let you know

Thanks
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!