Win a copy of Head First Android this week in the Android forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Tim Cooke
  • Junilu Lacar
Sheriffs:
  • Rob Spoor
  • Devaka Cooray
  • Jeanne Boyarsky
Saloon Keepers:
  • Jesse Silverman
  • Stephan van Hulst
  • Tim Moores
  • Carey Brown
  • Tim Holloway
Bartenders:
  • Jj Roberts
  • Al Hobbs
  • Piet Souris

Weblogic Portal Application Issue | Previous Page getting rendered

 
Ranch Hand
Posts: 244
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Problem:

A (Login) --> B (Reset Password) --> A (Login)


Submitting details on Page A takes to Page B. Clicking a link on Page B takes back to Page A. Making a selection in the header of Page A refreshes the page to change the locale of the page.


What must happen?
Page A should be refreshed. Since the refresh action of the page is set as begin, so begin of all the portlets on the page should be called. Page A i.e. login page with changed locale should be displayed.



What is happening?
Begin of Page B (which is a previous page) is getting called up. Result: Reset Password page is getting rendered and displayed.


Possible Actions:
1. I checked the render Cacheable property of the portlets to check if it is set to true. I was of the impression due to portlet caching mechanism; the previous portlet is called again.

2. When I click the back link on Page B (taking me to page), I have modified the URL as follows:
<a href="/coltPortalWeb/coltPortal.portal?_nfls=false">

Assuming that _nfls will reset the page on which action is done.

Yet the previous page is getting rendered. I am not getting any clue on what can be other possible issue. May be some property of portlet is required to be set. If anyone has faced such issue, please let me know.



Note:

The application is developed using Weblogic Portal 9.2 with AndroMDA.

Any quick help in this regard will be much appreciated. If you need more information feel free to get back to me.
 
You showed up just in time for the waffles! And this tiny ad:
Building a Better World in your Backyard by Paul Wheaton and Shawn Klassen-Koop
https://coderanch.com/wiki/718759/books/Building-World-Backyard-Paul-Wheaton
reply
    Bookmark Topic Watch Topic
  • New Topic