• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

RenderParameter problem

 
heba emara
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All,
I have a problem with clearing RenderParameters below is the scenrio that i am going through
First i am using JSR 168 on WebSphere Portal

In the processAction of the portlet i set a render parameter as following
response.setRenderParameter("paramname", "false");
i use the parameter in the view jsp as following
<% if(null != renderRequest.getParameter("paramname")
&& "true".equals(renderRequest.getParameter("paramname"))){ %>
Mainly i use the parameters to display error messages
My Problem is when i refresh the page or log out the page and return to it again the error messages are still due to the existance of the renderparameters
Thanks,
 
Cameron Wallace McKenzie
author and cow tipper
Saloon Keeper
Posts: 4968
1
Hibernate Spring Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The render parameters should be purged along with the request, so a new request shouldn't have the parameters attached to it.

Are you sure that the issue isn't page caching, as opposed to an issue with the render parameters?

-Cameron McKenzie
 
heba emara
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I checked the cache properties of the portal page containing the portlet and i found that cache option is setted to always expire the same for the portlet
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic