• Post Reply Bookmark Topic Watch Topic
  • New Topic

problem with ports

 
Jason Carroll
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello All,

on linux(2.4.21-32.ELsmp #1 SMP Fri Apr 15 21:17:59 EDT 2005 i686 i686 i386 GNU/Linux), when attempting to start tomcat5.0.28, I receive the error:

StandardServer.await: create[8080]: java.net.BindException: Address already in use
java.net.BindException: Address already in use

I have verified 8080 is not being used by any process.
I have changed the port in server.xml to 8888 and 88 and the same error results.
I have changed an apache ws to use port 8080 and apache opens 127.0.0.1:8080.

---- START DEBUG routine ----

1. running netstat -a while starting tomcat5.0.28

netstat -a reports:

tcp 0 0 0.0.0.0:8080 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:8080 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:8080 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:8080 0.0.0.0:* LISTEN
tcp 0 0 127.0.0.1:32835 127.0.0.1:8080 FIN_WAIT2
tcp 1 0 127.0.0.1:8080 127.0.0.1:32835 CLOSE_WAIT
tcp 0 0 0.0.0.0:8080 0.0.0.0:* LISTEN
tcp 0 0 127.0.0.1:32835 127.0.0.1:8080 FIN_WAIT2
tcp 1 0 127.0.0.1:8080 127.0.0.1:32835 CLOSE_WAIT
tcp 0 0 0.0.0.0:8080 0.0.0.0:* LISTEN
tcp 0 0 127.0.0.1:32835 127.0.0.1:8080 FIN_WAIT2
tcp 1 0 127.0.0.1:8080 127.0.0.1:32835 CLOSE_WAIT
tcp 0 0 0.0.0.0:8080 0.0.0.0:* LISTEN

SUMMARY: 0.0.0.0:8080 opens, but 127.0.0.1:8080 never opens


2. lo exists

lo is configured as follows:

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
SUMMARY: lo is configured

3. apache config
- edit httpd.conf to use 8080
- $apache_home/bin/httpd start
- apache runs on 127.0.0.1:8080

SUMMARY: apache uses 127.0.0.1:8080

---- END DEBUG routine ----

Any thoughts as to why tomcat5.0.28 will not open 127.0.0.1:8080?

Thank you,

Jason
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!