• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Problem with Communication API

aditya kakani
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello ,

i have been working with communications API..
recently i had to work on windows 2003 server and all the classes that worked with other OS in windows family like 2000 and XP have been giving me problems in 2003
the communication API i have set as i have been doing all the time at approriate places in jdk.
but in 2003 the class complies but dosent run and gives the following error

Exception in thread "main" java.lang.NoClassDefFoundError: javax/comm/SerialPortEventListene
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(Unknown Source)
at java.security.SecureClassLoader.defineClass(Unknown Source)
at java.net.URLClassLoader.defineClass(Unknown Source)
at java.net.URLClassLoader.access$100(Unknown Source)
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClassInternal(Unknown Source)

in other case these work fine when i work with netbeans and compile them in netbeans environment
i have tried setting class path in environment variables but all in vain

i have been greatly troubled by this

can anybody help me with this

thank you in advance

  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic