• Post Reply Bookmark Topic Watch Topic
  • New Topic

Trouble Starting Reggie  RSS feed

 
Muhammad Ali
Greenhorn
Posts: 28
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I am new to Jini stuff. Is any expert of RMI / Jini available?
"reggie" is giving me head aches and nightmares. I have tried all possible methods of starting this thing. The exact error I am receiving is
ExecGroup-0:err: Error in startup Activation.GroupInit
ExecGroup-0:err: java.rmi.activation.ActivationException: exception creating group
nested exception is java.lang.NullPointerException
:
:
I have successfully started the "http server" and "rmid" that are available with Jini. And a week ago, I even started "reggie" and the "lookup browser", but now its not working. There is no difference in the system / setting. I am using a Win 98 machine connected to a peer to peer LAN (two home PCs) with a static IP of 192.168.0.4.
The command lines are
rmid -J -Dsun.rmi.activation.execPolicy=none
java -jar c:\files\jini1_1\lib\tools.jar -port 8081 -dir c:\files\jini1_1\lib -verbose
java - jar c:\files\jini1_1\lib\reggie.jar http://localhost:8081/reggie-dl.jar c:\files\jini1_1\policy\policy.all c:\tmp\reggie_log public
Please help me out as timing is running by and I have a university project due this January. Help me, please
Muhammad Ali Shah
mashah@super.net.pk
[BCS VI - FAST Institute of Computer Science, Karachi - Pakistan]
 
Keith Edwards
Author
Greenhorn
Posts: 21
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Muhammad,
I'd double-check two things. First, make sure that the "java" executable program is available in the path in the command window in which you executed rmid. rmid needs to be able to find and launch new JVM instances to start activatable programs (like reggie). Second, I don't know if you've been previously working with earlier versions of Jini, but strange problems can occur if you're somehow mixing Jini versions...such as by having Jini 1.1 in your classpath, but Jini 1.0 in your webserver's directory, as referred to by your codebase URL.
Just as a couple of side notes:
- It's generally a good idea to never use "localhost" in a codebase. Using the actual machine name or IP address is better.
(see http://www.kedwards.com/jini/codebase.html for why this is so).
- In general, since reggie is activatable, you should only need to start it once ever. See http://www.kedwards.com/jini/reggie.html for an explanation.
I hope this helps.
-keith
Originally posted by Muhammad Ali:
Hi,
I am new to Jini stuff. Is any expert of RMI / Jini available?
"reggie" is giving me head aches and nightmares. I have tried all possible methods of starting this thing. The exact error I am receiving is
ExecGroup-0:err: Error in startup Activation.GroupInit
ExecGroup-0:err: java.rmi.activation.ActivationException: exception creating group
nested exception is java.lang.NullPointerException
:
:
I have successfully started the "http server" and "rmid" that are available with Jini. And a week ago, I even started "reggie" and the "lookup browser", but now its not working. There is no difference in the system / setting. I am using a Win 98 machine connected to a peer to peer LAN (two home PCs) with a static IP of 192.168.0.4.
The command lines are
rmid -J -Dsun.rmi.activation.execPolicy=none
java -jar c:\files\jini1_1\lib\tools.jar -port 8081 -dir c:\files\jini1_1\lib -verbose
java - jar c:\files\jini1_1\lib\reggie.jar http://localhost:8081/reggie-dl.jar c:\files\jini1_1\policy\policy.all c:\tmp\reggie_log public
Please help me out as timing is running by and I have a university project due this January. Help me, please
Muhammad Ali Shah
mashah@super.net.pk
[BCS VI - FAST Institute of Computer Science, Karachi - Pakistan]


------------------
keith edwards
xerox palo alto research center
author of: Core Jini
 
Lakshmi Nayak
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello !
I have just started working on Jini.I am encountering same problem as u with Reggie. Same exception of ActivationGroupInit.
I saw the reply u received from Keith Edwards. However I have already done all those things.
Can u please tell me how u fixed that bug in the end ?
Thanks in advance
Lakshmi
Originally posted by Muhammad Ali:
Hi,
I am new to Jini stuff. Is any expert of RMI / Jini available?
"reggie" is giving me head aches and nightmares. I have tried all possible methods of starting this thing. The exact error I am receiving is
ExecGroup-0:err: Error in startup Activation.GroupInit
ExecGroup-0:err: java.rmi.activation.ActivationException: exception creating group
nested exception is java.lang.NullPointerException
:
:
I have successfully started the "http server" and "rmid" that are available with Jini. And a week ago, I even started "reggie" and the "lookup browser", but now its not working. There is no difference in the system / setting. I am using a Win 98 machine connected to a peer to peer LAN (two home PCs) with a static IP of 192.168.0.4.
The command lines are
rmid -J -Dsun.rmi.activation.execPolicy=none
java -jar c:\files\jini1_1\lib\tools.jar -port 8081 -dir c:\files\jini1_1\lib -verbose
java - jar c:\files\jini1_1\lib\reggie.jar http://localhost:8081/reggie-dl.jar c:\files\jini1_1\policy\policy.all c:\tmp\reggie_log public
Please help me out as timing is running by and I have a university project due this January. Help me, please
Muhammad Ali Shah
mashah@super.net.pk
[BCS VI - FAST Institute of Computer Science, Karachi - Pakistan]

 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!