Win a copy of Murach's Python Programming this week in the Jython/Python forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

rmiregistry not working!  RSS feed

 
Geoffrey Falk
Ranch Hand
Posts: 171
1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am having problems starting the rmiregistry. This is straight out of the box on two different machines, and I am not doing anything unusual.
On Windows 2000 with JDK1.4.1_01-b01 under Cygwin and DOS shell:
% rmiregistry
java.rmi.RemoteException: failed to export: class gnu.java.rmi.dgc.DGCImpl
Exception in thread "main" java.lang.InternalError: Thread.start called but threads not available
[exit]
On FreeBSD 4.7 with the JDK1.3.1-p7 native port:
% rmiregistry
java.rmi.RemoteException: failed to export: class gnu.java.rmi.dgc.DGCImpl
[keeps running]
Any idea what is going on??? I used rmiregistry before without any such problems.
Thanks
Geoffrey
[ February 16, 2003: Message edited by: Geoffrey Falk ]
 
Geoffrey Falk
Ranch Hand
Posts: 171
1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Problem solved. Turns out that on both platforms I had old versions of the rmiregistry executable in another bin directory, earlier in the path. On both machines the old binary was left over from an earlier installation of a different JDK version.
This would seem an obvious thing to check, but the fact that it occurred on two separate machines really threw me off!
Sorry for the bandwidth..
Geoffrey
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!