• Post Reply Bookmark Topic Watch Topic
  • New Topic

RMI remote access error

 
Chris Shepherd
Ranch Hand
Posts: 286
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Just a brief question.
What could cause a RemoteAccess error to occur when I am hooked up through RMI to the loopback address(127.0.0.1)? I have a working system including RMI that functions great...until this problem occurs at widely spaced(days sometimes) random times. I can understand how I might see something like this over a network where you have other hardware in play and possible cabling issues, but how can that be a factor when connected to the loopback address? And its not like it never worked from the beginning. Its actually been working fine for months. Happens on multiple machines with identical code(linux). I'm setting up traps and such, but because of the large time frames between problems, I figured I'd ask and see if anyone has an inkling of what might be causing a loopback RemoteAccess error.
Thanks
 
Michael Ernest
High Plains Drifter
Sheriff
Posts: 7292
Netbeans IDE VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Remote access does not generally refer to a remote machine, but a remote process. If one process does not explicitly share some memory-mapped address space with another, it's "remote" because it would only be accessible through remote (i.e. network) semantics.
So two processes are "remote" even if they running on the same machine and use a network transport -- even loopback -- to communicate. Loopback is not a "false" network, so to speak. It follows the same rules of all network communication, with the simple provision that it doesn't actually use the physical network.
By the way, what's the full package name of the RemoteAccess class you are referring to?
[ December 16, 2003: Message edited by: Michael Ernest ]
 
Chris Shepherd
Ranch Hand
Posts: 286
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
thanks Michael. I'll have to try to trap one of the errors to find out the full package name. Does it matter? is there more than one?
Do you have any idea what could cause the network transport to fail when it never leaves my box? I know its a stretch asking, since you don't know my code/hardware/OS. I'm just at a loss for the moment on how to fix this event.
Thanks,
Chris
 
Michael Ernest
High Plains Drifter
Sheriff
Posts: 7292
Netbeans IDE VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I can probably help if I know more about what RemoteAccess does. It's not a standard class, so I am curious to learn what it is meant to describe.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!