• Post Reply Bookmark Topic Watch Topic
  • New Topic

internet explorer rmi problem

 
Maksim Kogan
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hey guys me again with my stupid rmi chat applet. it turns out that the problem is not with my code but with internet explorer. when ran in opera (which uses jre instead of the java plug-in) the program works perfectly no unmarshal exceptions no null pointer exceptions. has anyone seen this problem before? can anybody guess why this is happening? help would be much appreciated.
 
Chris Shepherd
Ranch Hand
Posts: 286
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
[ soapbox ]
because IE sucks
Sorry, I have no idea what the problem is. I just wanted to use this opportunity to slam explorer(and in a backhanded way those people who use it because they don't know any better. They are like sheep to the slaughter)
[/soapbox]
Hope someone else can help you with this.
Chris
 
Maksim Kogan
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i agree completely but there is a lot of them and so we must cater to them. i discovered that explorer needs a plugin to work with rmi but all the download links i've found so far are broken, i also couldnt find it on the msdn website (not that it will help terribly much since most people using this will not be able to install it themselves). but just for the sake of seeing that it could potentially work if anybody could give me the link if they know it that would be great.
 
Chris Shepherd
Ranch Hand
Posts: 286
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
BAH! Who needs the mainstream! Just cause I like to eat and buy new clothes once or twice a decade! Thats not a good enough reason to cater to the whims of the unwashed masses who don't know their head from a hole in the ground! BAH! If it wasn't for all the dang users, this would all be a moot point!
but anyways, perhaps a few questions would pique your brain cells into seeing a new way to attack the problem.
Where did the plug-in come from(sun?MS?). Are your versions the same between the plugin and whatever you compiled your class files with? Does it have to be? does it work with mozilla(or whatever their browser is called this week)? If you have the oportunity, does it work with Galleon(linux I think) or the mac browser? Do the plug-ins even support RMI?
Maybe one of these will spark an idea on why its not working
Chris
[ March 02, 2004: Message edited by: Chris Shepherd ]
 
Maksim Kogan
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
thanks for all your input chris. the program works fine in opera and firefox just not in IE or netscape. i didn't download msjvm, all i have are the j2re and j2se. both are 1.4.2. it seems as though i will have to depart from RMI, but i'd really rather not. so if anybody knows of anything that can make that microoft browser work with this, please do impart your knowledge on those that are less fortunate (and very very pissed off).
[ March 08, 2004: Message edited by: Maksim Kogan ]
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!