This week's book giveaway is in the HTML/CSS/JavaScript forum.
We're giving away four copies of Practical SVG and have Chris Coyier on-line!
See this thread for details.
Win a copy of Practical SVG this week in the HTML/CSS/JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

Java Version problem with Visibroker

 
Jeps Kand
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Everyone
I am facing a problem using some of the Java versions when we try to combine with the Visibroker (CORBA specification). We are getting the
following error when trying to access our software from a web browser that is using any Sun Java versions 1.3.2 and above.
ERROR:
"java.lang.VerifyError: class org.omg.PortableServer.AdapterActivatorPOA
overrides final method "
We dont get any error when we use a Java version 1.3.0 and
below. How do I rectify this problem?
Any help will be highly appreciated.
Thanks
JP
 
Nathan Pruett
Bartender
Posts: 4121
IntelliJ IDE Java Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What version of Visibroker are you using? It sounds like there is a problem because the OMG CORBA APIs were added to the standard JDK about the time of 1.3.2. Visibroker tries to load its version of the standard OMG classes, but gets the classes from the JDK instead... obviously it looks like they were implemented differently.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!