Help coderanch get a
new server
by contributing to the fundraiser
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

SimpleJxtaApp.java problem

 
Ranch Hand
Posts: 43
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I am using Windows XP with jdk1.5

1. I downlaoded SimpleJxtaApp.java from
"http://platform.jxta.org/source/browse/platform/www/java/tutorial/examples/SimpleJxtaApp/?only_with_tag=issue311" and put the file into to c:\test folder

2. Then I downloaded jxta-lib-2.3.2b.zip and unzipped all jar files to c:\test\lib folder


3. I used the following command to compile
set CLASSPATH=%CLASSPATH%;lib/jxta.jar;lib/log4j.jar;lib/org.mortbay.jetty.jar;lib/javax.servlet.jar;lib/bcprov-jdk14.jar
set JAVA_HOME=C:\Program Files\Java\jdk1.5.0_01
javac SimpleJxtaApp.java

I comipiled SuccessFully

4. I tried to run the program using following Code

set CLASSPATH=%CLASSPATH%;lib/jxta.jar;lib/log4j.jar;lib/org.mortbay.jetty.jar;lib/javax.servlet.jar;lib/bcprov-jdk14.jar
java -classpath . SimpleJxtaApp

But I get the error message as follow

'Exception in thread "main" java.lang.NoClassDefFoundError: net/jxta/exception/PeerGroupException'

I am very new to JXTA

Pls Help me
 
I child proofed my house but they still get in. Distract them with this tiny ad:
We need your help - Coderanch server fundraiser
https://coderanch.com/t/782867/Coderanch-server-fundraiser
reply
    Bookmark Topic Watch Topic
  • New Topic