Only 48 hours left in the trailboss' kickstarter!

New rewards and stretch goals. CLICK HERE!



  • Post Reply Bookmark Topic Watch Topic
  • New Topic

Coding compatible with POA and old CORBA  RSS feed

 
D Rog
Ranch Hand
Posts: 472
Linux Objective C Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have some code wich should be compatible with JDK 1.3 (oldImplBase) and new POA. Of course, I could stay with oldImplBase, however probably there is a simple solution to handle both.

Generally changes are not big:
Old style
public class myInterfaceImpl extends _myInterfaceImplBase {
New POA
public class myInterfaceImpl extends myInterfacePOA {

I'm thinking dynamically generate base classes like:
public class myInterfaceBase extends _myInterfaceImplBase {
} // for old

and

public class myInterfaceBase extends myInterfacePOA {
} // for new

and implemenation class should look like

public class myInterfaceImpl extends myInterfaceBase {

Since implementation of myInterfaceBase is a simple, then I can generate it dynamically by ant building procedure.

Can you see a better solution?
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!