Win a copy of Murach's Python Programming this week in the Jython/Python forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

Mac OSX NoSuchMethodError: Running a JSF Application on Tomcat 5.0.28  RSS feed

 
Jacob Briscoe
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm have a problem running the example application from Sun JSF(1.0): jsf-guessNumber. I have been fighting this for hours but have been unable to get JSF to run. Here is the exception being thrown:

javax.servlet.ServletException: javax.servlet.jsp.tagext.TagAttributeInfo.<init>(Ljava/lang/String;ZLjava/lang/String;ZZ)V
org.apache.jasper.servlet.JspServlet.service(JspServlet.java:244)



And here is the Root Cause:

java.lang.NoSuchMethodError: javax.servlet.jsp.tagext.TagAttributeInfo.<init>(Ljava/lang/String;ZLjava/lang/String;ZZ)V
org.apache.jasper.compiler.TagLibraryInfoImpl.createAttribute(TagLibraryInfoImpl.java:568)
org.apache.jasper.compiler.TagLibraryInfoImpl.createTagInfo(TagLibraryInfoImpl.java:401)
org.apache.jasper.compiler.TagLibraryInfoImpl.parseTLD(TagLibraryInfoImpl.java:248)
org.apache.jasper.compiler.TagLibraryInfoImpl.<init>(TagLibraryInfoImpl.java:179)




I haven't changed anything in the guess number war file, it is completly untouched when I get that error. It seems like Tomcat is unable to understand a JSF taglib in the guess number war file. The weird thing is that I'm able to get everything running properly under a Windows XP configuration. When I try this on Mac OSX it has this problem, I have tried to use the .tar.gz files and from the command line extract them because I knew there was an issue with Stuffit Expander not expanding these files properly but still I get the same error.
I cannot figure this out, if anyone has this working please let me know how you got everything running properly.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!