• Post Reply Bookmark Topic Watch Topic
  • New Topic

JSF issues with Tomcat 5.5.9  RSS feed

 
D Thompson
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All!

I have updated Tomcat from 5.0.28 to 5.5.9 while still running jdk 1.4.2 (butI have followed the compatibility instructions) and now my JSF application is not working. Has anyone experienced the following error:

javax.servlet.jsp.JspException: java.lang.LinkageError: Class javax/faces/context/FacesContext violates loader constraints
org.apache.jasper.runtime.PageContextImpl.doHandlePageException(PageContextImpl.java:844)

There are no other errors in the logs except this one!

Any help would be appreciated as I am stumped!!

thanks,

Dave Thompson
 
Gregg Bolinger
Ranch Hand
Posts: 15304
6
Chrome IntelliJ IDE Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
From the tomcat docs on 5.5:


If using a J2SE 1.4 JRE, the compatibility package must be downloaded and expanded inside the folder where Tomcat was installed.


Tomcat 5.5 wants Java 1.5. Maybe that is your issue?
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!