This week's book giveaway is in the Beginning Java forum.
We're giving away four copies of Learn Java with Math: Using Fun Projects and Games and have Ron Dai on-line!
See this thread for details.
Win a copy of Learn Java with Math: Using Fun Projects and Games this week in the Beginning Java forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Bear Bibeault
  • Junilu Lacar
  • Martin Vashko
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Knute Snortum
Saloon Keepers:
  • Ron McLeod
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Scott Selikoff
  • salvin francis
  • Piet Souris

selectOneMenu and dataTable

 
Ranch Hand
Posts: 15304
6
Mac OS X IntelliJ IDE Chrome
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I've got a selectOneMenu that contains a list of categories. There is an OK button that when pressed, submits the form which updates a parentCatId property to whatever is selected in the selectOneMenu.

I also have a dataTable that contains a list of subCategories for the selected category.

Problem: When the page is loaded and the list is populated with default subCategories, I click on one of the subCategories in the dataTable (commandLink) and display the details of said subCategory on the right side of the page. This works until....

I choose a different parentCategory from the selectOneMenu. The dataTable is populated with the new subCategories but when I click on a subCategory I still get the old details. There is a UIData property bound to the dataTable. I think that possibly, when I click the OK button, this model is not getting updated with the new list of subCategories.

Has anyone experienced this and/or know of a way to solve this?

Thanks.
 
Gregg Bolinger
Ranch Hand
Posts: 15304
6
Mac OS X IntelliJ IDE Chrome
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I added preserveDataModel="true" to my dataTable and it appears to be working, for now.
 
Hey cool! They got a blimp! But I have a tiny ad:
Sauce Labs - World's Largest Continuous Testing Cloud for Websites and Mobile Apps
https://coderanch.com/t/722574/Sauce-Labs-World-Largest-Continuous
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!