Win a copy of Cross-Platform Desktop Applications: Using Node, Electron, and NW.js this week in the JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

Problem configuring RichFaces3.2.1GA, JSF1.2 and Tomcat6+Eclipse3.4  RSS feed

 
anandram venkataswamy
Greenhorn
Posts: 9
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I configured the richfaces-ui-3.2.1 with my JSF1.2 project. I get the following error

MY Setting:

Web.xml:



My RichFaces Lib:

richfaces-api-3.2.1.GA.jar
richfaces-impl-3.2.1.GA.jar
richfaces-ui-3.2.1.GA.jar


ERROR:


can anybody help me to get through this problem,

thankyou in advance.

regards,
Anandram
anandramv@gmail.com
 
Cosmin Juravle
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
It looks like you did not add all dependencies of RichFaces, specifically in your case the commons-logging.jar. Check the right version on the JBoss RichFaces website.
Make sure you have all dependencies of every jar you add.
Obviously I recommend maven for that.
 
Robson Vargas Peerless
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
If the problem continue, i dont know, but can work. Try delete the 'work' folder of tomcat.
 
anandram venkataswamy
Greenhorn
Posts: 9
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hello all,
Thankyou verymuch for the reply, I have successfully configured richfaces.added all dependencies files for Richfaces :

common-annotations.jar
commons-beanutils.jar
commons-collections-3.2.1.jar
commons-digester.jar
commons-logging-1.0.4.jar

After adding them I have even included richfaces in
JavaEE module Dependency
of exsisting JSF project in Eclipse3.4

Now my problem is solved.




with warm regards,
Anandram.V
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!