Win a copy of Java 9 Modularity: Patterns and Practices for Developing Maintainable Applications this week in the Java 9 forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

Websphere studio Hibernate Synchronizer plugin install issue  RSS feed

 
Helen Ge
Ranch Hand
Posts: 68
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I opened WASD 5.1.1 to install Hibernate Synchronizer and opened the Update Manager by choosing Help -> Software Updates -> Update Manager.

Opened the Install/Update perspective, right-click on the Feature Updates view and choose New -> Site Bookmark

I enetered the Name: Hibernate Synchronizer, and the URL as http://hibernatesynch.sourceforge.net/


I go to the bookmark in WASD, and click the install now button and get the following error:

Requested operation cannot be performed because it would invalidate the current configuration. See details for more information.
Hibernate Synchronizer (2.3.1): Feature requires plug-in "org.eclipse.osgi".
Hibernate Synchronizer (2.3.1): Feature requires plug-in "org.eclipse.ui.ide".

Can someone give me a help here? - should I install the other two plugin as mentioned above in order to plugin the Hibernate Synchronizer?


Thanks
-Helen

[ May 09, 2007: Message edited by: Helen Li ]
[ May 09, 2007: Message edited by: Helen Li ]
 
saranga rao
Ranch Hand
Posts: 49
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

first UnZip the http://hibernatesynch.sourceforge.net/ in the /eclipse-home/plugin/ and go to Help -> Software Updates -> Update Manager.

click on second radio button.....click on the
--->New Archived Site ---> give the Zip file path ........

click on the finish...

Open in the Hibernate Sync Mode You are in the hiberante Sync Perspertive
 
Helen Ge
Ranch Hand
Posts: 68
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks saranga !

However I am not be able to follow what you told me - I can not see anywhere in the Features Update window has the second radio option for the archieved file path. Maybe you are using different version of Eclipse / WSAD???


This is what I did:

In my WSAD 5.1.1, go help--> Software Update --> Update Manager
-->Features Update window-->right click and choose
new --> Site Bookmark --> enter the name "Hibernate Syncronizer" , URL as "http://hibernatesynch.sourceforge.net/" and choose the first radio button "Eclipse Update Site" --> finish --> go back to the features update window --> expend the Hibernate Syncronizer and choose install.

Then I got the error:

Requested operation cannot be performed because it would invalidate the current configuration. See details for more information.
Hibernate Synchronizer (2.3.1): Feature requires plug-in "org.eclipse.osgi".
Hibernate Synchronizer (2.3.1): Feature requires plug-in "org.eclipse.ui.ide".


Can you tell me more??

thanks

Helen
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!