Win a copy of Cross-Platform Desktop Applications: Using Node, Electron, and NW.js this week in the JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

jwsdp - paths  RSS feed

Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am experiencing problems specifying the correct path settings for
the jwsdp tutorial examples to compile and run.
1. I installed jwsdp-1_0_01 on C drive.
2. Extracted the Tutorial Zip to the same
folder - jwsdp-1_0_01 - on C drive.
3. set the Home and Path variables as follows;
JWSDP_HOME - C:\jwsdp-1_0_01
PATH - C:\jwsdp-1_0_01\bin;C:\jdk1.3.1_02\bin;
4. Inserted the build.xml (in the GS directory)
and (in the jwsdp-1_0_01)

5. Navigated to the GS directory in the tutorial
6. Typed ant
Got the following error:

Buildfile: build.xml
Caught exception ( while expanding classpath
: C:\jwsdp-1_0_01\docs\tutorial\examples\gs\${jwsdp.home}\common\lib not found.
[taskdef] dropping C:\jakarta-ant-1.6alpha\lib\xmlrt.jar from path as it doesn't exist
file:C:/jwsdp-1_0_01/docs/tutorial/examples/gs/build.xml:65: taskdef class org.a
pache.catalina.ant.InstallTask cannot be found
Total time: 1 second
7. I have tried installing the jwsdp-1-_0_01 to the default directory c ocuments and Settings\baska
and followed the Set Up instructions to the letter.
I have also tried removing C:\jakarta-ant-1.6alpha - which was set for the Ant_Home for the J2EE Package - and used the ANT that comes packaged with
Any Ideas -- What am I doing wrong.........
Thanks very much......
Rich Raposa
Ranch Hand
Posts: 46
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm not sure if this will fix your problem, but here is a batch file that I run when using the JWSDP:
set CLASSPATH=%jwsdp_home%\common\lib\saaj-api.jar;%jwsdp_home%\common\lib\servlet.jar;%jwsdp_home%\common\lib\jaxm-api.jar;.;%jwsdp_home%\common\lib\saaj-ri.jar;%jwsdp_home%\common\lib\commons-logging.jar;%jwsdp_home%\common\lib\jaxm-runtime.jar;%jwsdp_home%\common\lib\mail.jar;%jwsdp_home%\common\lib\activation.jar;%jwsdp_home%\common\lib\dom4j.jar;
It's probably worth a try. I have not had any problems, but I also haven't tried deploying the examples, just my own stuff.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!