Win a copy of Kotlin in Action this week in the Kotlin forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

Why can't I import these classes?  RSS feed

 
Dominic Clarke
Greenhorn
Posts: 11
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello Ranchpeople!
This is a jsp problem, but...................
My problem lies in the field of web services (I want to setup a simple web service), but I've fallen at the first hurdle when trying to use the Apache admin tool for deploying web services.
Basically, I'm using Tomcat to deploy my services, but whenever I try to access the deploy page (List.jsp), I'm greeted with this error:

org.apache.jasper.JasperException: Unable to compile class for JSP
An error occurred at line: 4 in the jsp file: /admin/list.jsp
Generated servlet error:
[javac] Compiling 1 source file
C:\Tomcat 4.1\work\Standalone\localhost\soap\admin\list_jsp.java:8: cannot resolve symbol
symbol : class Constants
location: package soap
import org.apache.soap.Constants;
^
C:\Tomcat 4.1\work\Standalone\localhost\soap\admin\list_jsp.java:9: package org.apache.soap.server does not exist
import org.apache.soap.server.*;
^
C:\Tomcat 4.1\work\Standalone\localhost\soap\admin\list_jsp.java:48: cannot resolve symbol
symbol : variable Constants
location: class org.apache.jsp.list_jsp
String configFilename = config.getInitParameter(Constants.CONFIGFILENAME);
.......etc........etc..............
So, basically, it's having problems importing "org.apache.soap.Constants", and "org.apache.soap.server.*", and I don't know why this is!!!
I've tried puuting these classes into my Tomcat directory, in my J2EE/lib directory, setting CLASSPATH's so they point to these classes, but still it wont work! (Ihave tried EVERYTHING I can think of)
Would it have anything to do with web.xml maybe?
Can anybody give me some help, because it's driving me nuts......

Thanks
 
Don't get me started about those stupid light bulbs.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!